WordPress 4.2.1 Critical Security Release

By | April 28, 2015

WordPress 4.2.1 Security Release

WordPress 4.2.1 is now available. This is a critical security release for all previous versions and we strongly encourage you to update your sites immediately. April 27, 2015 the WordPress team was made aware of a cross-site scripting vulnerability, which could enable commenters to compromise a site.

If your web site is powered by WordPress, please upgrade it ASAP, here is the procedure we recommend:
1- Backup your Hosting account using your account’s Plesk Panel Backup Manager
2- Upgrade WordPress. There are 2 ways of doing that:
  • ┬áIf you installed WordPress from the Plesk Panel Applications tab, you can upgrade it from the Panel
  • If you installed WordPress yourself, login to your WordPress Admin Dashboard and upgrade it from there
3- Check that everything is working.
4- Backup your upgraded installation as a precaution.